Join Together v5.4 for pre Snow Leopard operating systems

Join Together v5.4 works with machines running Mac OS 10.4.11 or Mac OS 10.5.8. It will not work very well at all on machines running 10.6 or better. For that, use the latest version of Join Together.

Upgrade

You can purchase an upgrade code for Join Together v5.4 via the Join Together main page.

Site contents © 2001 - 2014 Doug Adams and weblished by Doug Adams, dougscripts AT mac DOT com. About.
All rights reserved. Legal.
AppleScript, iTunes, iPod, iPad, and iPhone are registered trademarks of Apple Inc.