Track GPR

v2.7

For iTunes 11+/macOS 10.10+
Find more free AppleScripts

and info on writing your own

at Doug's AppleScripts for iTunes.

This applet will assist with associating replacement
files to a batch of dead tracks (iTunes tracks whose
files are missing/inaccessible as signified with a "!").

For macOS 10.10 and later only.

This script is Donationware. If you use it and like it
please consider making a donation to support my
AppleScripting efforts. Click here for more info.

Installation:

This script is an AppleScript applet and can be run by double-clicking its icon in the
Finder. However, it is probably best accessed from the iTunes Script menu.

Put AppleScripts in your iTunes "Scripts" folder. This is located at [user name] /
Library / iTunes / Scripts /.

The user Library directory is hidden by default. To make it visible, hold down the
Option key on your keyboard and select Go > Library from the Finder.

If the [user name] / Library /folder does not contain the "iTunes" or "Scripts" folders
then then create them and put the script(s) in the "Scripts" folder. AppleScripts will
then appear in iTunes' Script menu, and can be activated by selecting by name and
clicking. Be sure to also save this Read Me document in a safe and convenient place.

See the online Download FAQ for more info and video on downloading and
installing AppleScripts.


https://dougscripts.com/itunes/
https://dougscripts.com/itunes/itinfo/donate.php
https://dougscripts.com/itunes/itinfo/donate.php
https://dougscripts.com/itunes/itinfo/downloadfaq.php

How to use:

Using the script to re-associate dead tracks with new files is a 3 Step Process. Here's
a Quick Start, but be sure to read the Important Notes & Caveats section below, too.

And: you may be tempted to replace all your dead tracks in one swoop. Resist. Do
Not Do That.

1 ) Launch the script. When its main window displays, click the Scan for Dead

Tracks button in the lower left of the window. It will take a few moments to scan your
current iTunes library for tracks with missing or inaccessible files. These "dead tracks"
will be displayed in Track CPR's main window with extant file information:

[ JON | Track CPR
Artist Album  ~ Name Last Known Location Last Known File Name
Janis Joplin | Pearl A Woman Left Lonely Nolumes/Main/iTunes on Main2/iTunes MediaMu... | A Woman Left Lonely.mdp
Janis Joplin | Pearl Buried Alive In the Blues Nolumes/Main/iTunes on Main2/iTunes Media/Mu... Buried Alive In the Blues.mdp
Janis Joplin  Pearl Cry Baby Nolumes/Main/iTunes on Main2/iTunes MediaMu... |Cry Baby.mdp
Janis Joplin | Pearl Cry Baby (Live) Nolumes/Main/iTunes on Main2/iTunes MediaMu... | Cry Baby (Live).mdp
Janis Joplin | Pearl Get It While You Can Nolumes/Main/iTunes on Main2/iTunes MediaMu... | Get It While You Can.mdp
Janis Joplin | Pearl Half Moon Nolumes/Main/iTunes on Main2/iTunes MediaMu... | Half Moon.mdp
Janis Joplin | Pearl Little Girl Blue (Live) Nolumes/Main/iTunes on Main2/iTunes MediaMu... | Little Girl Blue (Live). mdp
Janis Joplin | Pearl Me and Bobby McGee Nolumes/Main/iTunes on Main2/iTunes Media/Mu... | Me and Bobby McGee.mdp
Janis Joplin | Pearl Mercedes Benz Nolumes/Main/iTunes on Main2/iTunes MediaMu... | Mercedes Benz.mdp
Janis Joplin | Pearl Move Over Nolumes/Main/iTunes on Main2/iTunes Media/Mu... | Move Over.mdp
Janis Joplin | Pearl My Baby Nolumes/Main/iTunes on Main2/iTunes MediaMu... | My Baby.mdp
Janis Joplin | Pearl Tell Mama (Live) Nolumes/Main/iTunes on Main2/iTunes Media/Mu... | Tell Mama (Live).mdp
Janis Joplin | Pearl Trust Me Nolumes/Main/iTunes on Main2/iTunes MediaMu... | Trust Me.mdp

22 files are unavailable/inaccessible

Scan for Dead Tracks

For best reults, resize the main window horizontally to display as much information as

possible.

The "Last Known Location" and "Last Known File Name" entries are derived from
each dead track's last known file path according to iTunes' own database. iTunes has
determined (and the script has verified) that these files are either no longer available
or are currently inaccessible.



2) Select some of the dead tracks in the list. An album's worth of tracks is a good
start:

| NN | Track CPR
Artist Album Last Known Location Last Known File Name
Janis Joplin |Pearl A Woman Left Lonely Nolumes/Main/fiTunes on Main2/iTunes Media/Mu... | A Woman Left Lonely.mdp

Janis Joplin |Pearl Buried Alive In the Blues Nolumes/Main/iTunes on Main2/iTunes MediaMu... | Buried Alive In the Blues.mdp
Janis Joplin |Pearl Cry Baby Nolumes/Main/iTunes on Main2/iTunes MediaMu... | Cry Baby.m4p

Janis Joplin |Pearl Cry Baby (Live) Nolumes/Main/iTunes on Main2/iTunes MediaMu... | Cry Baby (Live).m4p

Janis Joplin | Pearl Half Moon Nolumes/Main/fiTunes on Main2/iTunes MediaMu... | Half Moon.mdp

Janis Joplin |Pearl Little Girl Blue (Live) Nolumes/Main/iTunes on Main2/iTunes MediaMu... | Little Girl Blue (Live).mdp
Janis Joplin |Pearl Me and Bobby McGee Nolumes/Main/fiTunes on Main2/iTunes MediaMu... | Me and Bobby McGee.mdp
Janis Joplin |Pearl Mercedes Benz Nolumes/MainfiTunes on Main2/iTunes MediaMu... | Mercedes Benz.mdp

Janis Joplin |Pear Move Over Nolumes/Main/iTunes on Main2/iTunes MediaMu... | Move Over.mdp

Janis Joplin |Pearl My Baby Nolumes/Main/iTunes on Main2/iTunes MediaMu... | My Baby.mdp

Janis Joplin |Pearl Tell Mama (Live) Nolumes/Main/fiTunes on Main2/iTunes MediaMu... | Tell Mama (Live). mdp

Janis Joplin |Pearl Trust Me Nolumes/Main/iTunes on Main2/iTunes MediaMu... | Trust Me.mdp
Delete 22 files are unavailable/i ible - 14 selected

~ Name

Click the button and select a folder containing same-named files...

Choose Folder of Files...

When you do, the Choose Folder of Files... button becomes enabled. Click this
button to display a standard Open Panel. Navigate to and select a folder which
contains the audio files you want to associate with the dead tracks you have selected.

IMPORTANT: The script will rescursively search the chosen folder for a single file
with the exact same filename as each missing file of the selected dead tracks (as
displayed in the "Last Known File Name" column). If more than one same-named file
is found anywhere within the chosen folder (at any level) then none of them will be
considered as viable replacements. For best results, select a folder as near to a
potential replacement file as possible. For example, the ALBUM folder in a path like
MUSIC/ARTIST/ALBUM/FILENAME.EXT. It also may be possible to choose the
ARTIST folder in that configuration as long as it doesn't contain more than one
matching filename in any of its sub-folders (a "greatest hits" aloum could be a
problem, for example).

If there is a single file in the chosen folder (at any level) that matches the filename of
one of the selected dead tracks, it will be listed and colored blue along-side the track
in the list with a blue checkmark in the far left column:



Track CPR

Artist Album ~ Name Last Kno... Last Known File Name New File Location
¥ Janis Joplin Pearl AWoman Left Lonely /NVolume... AWoman Left Lo... /NVolumes/Macintosh HD/Pearl/A Woman Left Lonely.mdp
¥ Janis Joplin Pearl Buried Alive In the... /Nolume... Buried Alive Inth... | /Nolumes/Macintosh HD/Pearl/Buried Alive In the Blues.m
¥ | Janis Joplin Pearl Cry Baby Volume... Cry Baby.m4dp Nolumes/Macintosh HD/Pearl/Cry Baby.mdp
¥ | Janis Joplin Pearl Cry Baby (Live) Volume... Cry Baby (Live).mdp | Molumes/Macintosh HD/Pearl/Cry Baby (Live).mdp
v Janis Joplin Pearl Get It While You Can Nolume... Get It While You... |/MNVolumes/Macintosh HD/Pearl/Get It While You Can.mdp
¥ Janis Joplin Pearl Half Moon Nolume... Half Moon.mdp Nolumes/Macintosh HD/Pearl/Half Moon.mdp
¥ Janis Joplin Pearl Little Girl Blue (Live) /NVolume... Little Girl Blue (Li... /Volumes/Macintosh HD/Pearl/Little Girl Blue (Live).mdp
¥ Janis Joplin Pearl Me and Bobby Mc... /Nolume... Me and Bobby M... | Nolumes/Macintosh HD/Pearl/Me and Bobby McGee.m4g
¥ Janis Joplin Pearl Mercedes Benz Mercedes Benz.mdp | /Nolumes/Macintosh HD/Pearl/Mercedes Benz.m4p
¥ | Janis Joplin Pearl Move Over olume... Move Over.mdp Nolumes/Macintosh HD/Pearl/Move Over.mép
v Janis Joplin Pearl My Baby Volume... My Baby.mdp Nolumes/Macintosh HD/Pearl/My Baby.mdp
¥ Janis Joplin Pearl Tell Mama (Live) Nolume... Tell Mama (Live).... /NVolumesMacintosh HD/Pearl/Tell Mama (Live).mdp

22 files are unavailable/inaccessible

Apply CPR to v Tracks

* You may want to consider manually editing the filenames of any source files ahead
of time to ensure that Track CPR will match them to the dead tracks' last known
filenames (or, see "How to Cheat", below).

3) If there are any entries in the list that are blue-checkmarked after examining the

chosen folder, the Apply CPR to v Tracks button becomes enabled. Click this button
to have Track CPR reassign each checkmarked track's Location property with the file
it found. None of the original dead track's meta-data will be lost.

Only checkmarked tracks will be processed. Prior to clicking on the Apply CPR to
v Tracks button, the checkmark for any entry with a replacement file can be toggled
off or on by selecting it and using the Edit > Toggle Checkmark of Selected menu
command or the keyboard shortcut Shift-Command-X.

IMPORTANT: Replacement files will remain in their current location.
Technically, you are not really "adding" a file to iTunes and thus iTunes will not be
compelled to copy the file to the iTunes Media folder. So, unless the files are already
located in the "iTunes Media" folder they will not be moved or copied there
automatically by iTunes or otherwise.

* You may want to consider moving matching-named files into their "final resting place"
before launching Track CPR.

Tracks that are successfully associated with the files in iTunes will be removed from
the Track CPR list.



Editing the Filename (or How to Cheat)

The text in the "Last Known File Name" column can be user-edited. This capability — if
used thoughtfully, see Cautions below — can assist with re-associating similarly
named files instead of relying on an exact match for the original filename. Essentially,
you can force a match.

Remember that the script will try to match the "Last Known File Name" of a particular
track entry when it searches your selected folder. It may be advantageous to search
for a slightly different filename instead of the filename of the original file.

For example, let us say that a set of album tracks' files have filenames that each begin
with their play order number. But the files you want to re-associate with them do not
start with numbers. Or perhaps they have a different file extension. Before you
"Choose Folder of Files...", simply click the filename in the list (in the "Last Known File
Name" column) and edit it accordingly. Press the Return key to end editing.

When you eventually "Choose Folder of Files..." the script will attempt to match the
newly edited text instead of the original filename.

IMPORTANT CAUTIONS ABOUT USING THIS EDITING "CHEAT" The trick to this
script is that it is replacing a missing file with a same-named file. However, using a file
with a filename other than the one iTunes is expecting (by using this "cheat") could
cause problems:

+ iTunes may presume such a file is a new file being added.

+ A found file's metadata may over-write the original track's tag data in iTunes after
being re-associated.

« If the file already exists in iTunes and is already assigned to another track, you may
induce some additional confusion.

* This feature can also cause havoc if used with iCloud Music Library, in which case
its use is NOT RECOMMENDED.

Important Notes & Caveats!

+ This app is an assistive tool not a one-click miracle worker.

+ This bears repeating: Any folder of replacement files that you select must contain
only one file whose filename is the same as one of the operative dead tracks' missing
files in order to be considered as the single viable replacement file for that track. There
is no simple, consistent and accurate way to assign an arbitrary batch of files to an



arbitrary batch of iTunes tracks without knowing which file should be associated with a
particular track. The last known filename is the only dependable "fingerprint" that the
track entry and the file have in common. And the script cannot efficiently determine
that something named "Love Me Do.mp3" may be the same as something named
"Love Me Do (Mono).mp3" or "08 Love Me Do.m4a", or any number of other
possibilities.

- Don't go fishing! Don't choose the topmost possible folder hoping that the
filename(s) you require are somewhere in there. Know your target folder.

- FOR BEST RESULTS perform replacements on a small number of tracks at a time.
It reduces the chance of multiple-same-named files being found within the selected
folder. Then perform CPR after you have matched several batches of selected tracks.

* The replacement operation cannot be undone with the script.

« iCloud Music Library/iTunes Match may report each new track's iCloud Status
as "Error" or "Waiting" until it eventually updates. Replacing the file like this may
confuse track syncing. Of course, if you're replacing a dead track, perhaps it isn'tin
the cloud anyway.

Additional Tools & Keyboard Shortcuts

Toolbar Buttons

Show (Command-L) - reveal a selected dead track in iTunes

Delete (Command-Delete) - remove selected dead tracks from the Track CPR list.
Has no effect on tracks in iTunes.

Reveal (Shift-Command-R) - (enabled after any replacement files have been listed)
reveal a selected file in the Finder

Menu Commands

File > Re-Scan (Command-R) - Re-scan iTunes for dead tracks. The current list will
be replaced and updated.

Edit > Select All (Command-A) - select all the dead tracks in the list

Edit > Select None (Shift-Command-A) - de-select the current selection

Edit > Invert Selection (Shift-Command-I) - invert the current selection

Edit > Toggle Checkmark of Selected (Shift-Command-X) - Toggle the checkmark
on or off for selected eligible tracks



View > Toggle Text Size (Command-+) - Change the size of the text in the list big or
small

Helpful Links:

Information and download link for this script is located at:
https://dougscripts.com/itunes/scripts/ss.php?sp=trackcpr

If you have any trouble with this script, please email me.
My name is Doug Adams
support@dougscripts.com

Click on the underlined URL text:

- Doug's AppleScripts for iTunes

- Assign Shortcut Keys to AppleScripts

- Doug's RSS Feed - Recent site news, script additions and updates (add link to
your news reader)

- 30 Most Recent RSS Feed - Most recent new and updated scripts (add link to
your news reader)

Version History:

v2.7 October 24, 2017

- Updated with accommodations for macOS 10.13 High Sierra
- Allows user-edit of source filename

- Preserves selection after "not found" result

- Minor maintenance and security fixes

v2.6 May 29, 2017

- Accommodates playlist windows in iTunes 12.6 and later
- Minor maintenance

- Fixes compatibility issue with macOS 10.12.5

- This version for macOS 10.10 and later only

v2.5 July 14, 2016
- Fixes “flickering” issue in column headers
- Preliminary support for macOS 10.12

v2.4 December 3, 2015

- Accommodates changes in iTunes 12.4
- Faster “dead track” analysis

- Minor security and maintenance fixes

v2.3 December 3, 2015
- Fixes text encoding issue
- Ignores app tracksf/files


https://dougscripts.com/itunes/scripts/ss.php?sp=trackcpr
mailto:support@dougscripts.com
https://dougscripts.com/itunes/
https://dougscripts.com/itunes/itinfo/shortcutkeys.php
https://dougscripts.com/itunes/dougs.rss
https://dougscripts.com/itunes/dougsupdated.rss

v2.2 July 15, 2015
- Preliminary support for OS X 10.11 (El Capitan)
- Accommodates changes in iTunes 12.2

v2.1 November 16, 2014

- Fixes for Yosemite compatibility

- Fixes issue with false positives

- Fixes issue with reading file paths on shared volumes

v2.0 October 23, 2014

- Adds support for OS X 10.10 Yosemite/iTunes 12
- Adds “Check for Update” command

- Mnor performance tweaks

v1.0 June 4, 2014
- initial release (based on very old "iTunes Track CPR")

This doc last updated October 24, 2017

This software is released "as-is". By using it or modifying it you agree that its author cannot be held
responsible or liable for any tragedies resulting thereof.

AppleScript, iTunes, iPhone, iPad and iPod are registered trademarks of Apple Inc.


http://www.apple.com

